読者です 読者をやめる 読者になる 読者になる

TakayukiKoyama Geek Blog

Create, Entertain, Experience

source :rubygemsでWarningが出るときは

Ruby

 bundleしたときに以下の様なメッセージが出た時の対策。

メッセージ

$ bundle 
The source :rubygems is deprecated because HTTP requests are insecure.
Please change your source to 'https://rubygems.org' if possible, or 'http://rubygems.org' if not.

修正方法

変更前

$ source :rubygems

変更後

$ source 'https://rubygems.org'

 ただ、メッセージが出るとはいえ、勝手に『https://rubygems.org』で処理されるのでそのままでも別にいいような気がしないでもない。

広告を非表示にする